Paypal Outage
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted 16 days ago. Sep 30, 2019 - 17:46 EDT
Investigating
We are experiencing issues caused by a Paypal outage. Our development team is closely monitoring the situation. We will provide further updates as soon as they become available.
Posted 17 days ago. Sep 30, 2019 - 12:44 EDT
This incident affected: Checking Out / Payment Processing.