Checkout Issues
Incident Report for Teachable
Resolved
This incident has been resolved.
Posted 10 months ago. Sep 12, 2017 - 17:05 EDT
Investigating
Our engineering team is investigating the source of errors impacting student checkout.

We will provide an update as soon as there’s additional information available.
Posted 10 months ago. Sep 12, 2017 - 16:41 EDT